nixos-selfhost/ai.nix
2025-01-14 15:17:47 +01:00

21 lines
312 B
Nix

{
self,
config,
lib,
pkgs,
...
}: let
domain = "ai.sondell.org";
in {
services.nginx.virtualHosts = {
${domain} = {
locations."/" = {
proxyPass = "http://localhost:9876/";
proxyWebsockets = true;
};
# Use DNS Challenege.
# acmeRoot = null;
};
};
}