18 lines
298 B
Nix
18 lines
298 B
Nix
{...}: let
|
|
domain = "books.sondell.org";
|
|
in {
|
|
#
|
|
services.audiobookshelf = {
|
|
enable = true;
|
|
port = 8000;
|
|
};
|
|
|
|
services.nginx.virtualHosts.${domain} = {
|
|
default = true;
|
|
locations."/" = {
|
|
proxyPass = "http://localhost:8000/";
|
|
proxyWebsockets = true;
|
|
};
|
|
};
|
|
}
|