205 lines
5.8 KiB
Nix
205 lines
5.8 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page
|
||
# and in the NixOS manual (accessible by running ‘nixos-help’).
|
||
{
|
||
config,
|
||
pkgs,
|
||
...
|
||
}: {
|
||
imports = [
|
||
# Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
];
|
||
|
||
services.postgresql = {
|
||
dataDir = "/pool/var/lib/postgresql/${config.services.postgresql.package.psqlSchema}";
|
||
};
|
||
|
||
nix.settings.experimental-features = ["nix-command" "flakes"];
|
||
powerManagement.enable = false;
|
||
|
||
# Bootloader.
|
||
boot.loader.grub.enable = true;
|
||
boot.loader.grub.device = "/dev/sdc";
|
||
boot.loader.grub.useOSProber = true;
|
||
networking = {
|
||
hostName = "nixos"; # Define your hostname.
|
||
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
|
||
|
||
# Configure network proxy if necessary
|
||
# networking.proxy.default = "http://user:password@proxy:port/";
|
||
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
|
||
|
||
# Enable networking
|
||
networkmanager.enable = true;
|
||
|
||
# Open ports in the firewall.
|
||
firewall.allowedTCPPorts = [80 443];
|
||
|
||
extraHosts = ''
|
||
192.168.1.88 nas
|
||
'';
|
||
};
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Europe/Stockholm";
|
||
|
||
# Select internationalisation properties.
|
||
i18n.defaultLocale = "en_US.UTF-8";
|
||
|
||
i18n.extraLocaleSettings = {
|
||
LC_ADDRESS = "sv_SE.UTF-8";
|
||
LC_IDENTIFICATION = "sv_SE.UTF-8";
|
||
LC_MEASUREMENT = "sv_SE.UTF-8";
|
||
LC_MONETARY = "sv_SE.UTF-8";
|
||
LC_NAME = "sv_SE.UTF-8";
|
||
LC_NUMERIC = "sv_SE.UTF-8";
|
||
LC_PAPER = "sv_SE.UTF-8";
|
||
LC_TELEPHONE = "sv_SE.UTF-8";
|
||
LC_TIME = "sv_SE.UTF-8";
|
||
};
|
||
|
||
# Enable the X11 windowing system.
|
||
services.xserver.enable = true;
|
||
|
||
# Enable the XFCE Desktop Environment.
|
||
# services.xserver.displayManager.lightdm.enable = true;
|
||
# services.xserver.desktopManager.xfce.enable = true;
|
||
services.xserver.desktopManager.plasma5.enable = true;
|
||
|
||
# Enable automatic login for the user.
|
||
services.xserver.displayManager.autoLogin.enable = true;
|
||
services.xserver.displayManager.autoLogin.user = "sondell";
|
||
|
||
# Configure keymap in X11
|
||
services.xserver = {
|
||
layout = "se";
|
||
xkbVariant = "";
|
||
};
|
||
|
||
# Configure console keymap
|
||
console.keyMap = "sv-latin1";
|
||
|
||
# Enable CUPS to print documents.
|
||
services.printing.enable = true;
|
||
|
||
# Enable sound with pipewire.
|
||
hardware.pulseaudio.enable = false;
|
||
security.rtkit.enable = true;
|
||
services.pipewire = {
|
||
enable = true;
|
||
alsa.enable = true;
|
||
alsa.support32Bit = true;
|
||
pulse.enable = true;
|
||
# If you want to use JACK applications, uncomment this
|
||
#jack.enable = true;
|
||
|
||
# use the example session manager (no others are packaged yet so this is enabled by default,
|
||
# no need to redefine it in your config for now)
|
||
#media-session.enable = true;
|
||
};
|
||
|
||
# Enable touchpad support (enabled default in most desktopManager).
|
||
# services.xserver.libinput.enable = true;
|
||
|
||
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
users.users.sondell = {
|
||
home = "/home/sondell";
|
||
isNormalUser = true;
|
||
description = "sondell";
|
||
extraGroups = ["networkmanager" "wheel" "backup" "opendkim"];
|
||
packages = with pkgs; [
|
||
firefox
|
||
# thunderbird
|
||
];
|
||
};
|
||
# users.groups."backup".gid = 1337;
|
||
|
||
users.users.root = {
|
||
isNormalUser = false;
|
||
openssh.authorizedKeys.keys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMYGJCpFIiWqzy8YbfWh7+i52XVwyhUu+P0rUglVR5uV gws@nixos"];
|
||
};
|
||
|
||
# Allow unfree packages
|
||
nixpkgs.config.allowUnfree = true;
|
||
|
||
# List packages installed in system profile. To search, run:
|
||
# $ nix search wget
|
||
environment.systemPackages = with pkgs; [
|
||
local-ai #does not build
|
||
alejandra
|
||
restic
|
||
htop
|
||
cloudflared
|
||
filebrowser
|
||
dufs
|
||
git
|
||
git-graph
|
||
gitui
|
||
helix
|
||
nil
|
||
starship
|
||
tailscale
|
||
alejandra
|
||
];
|
||
programs = {
|
||
ssh.startAgent = true;
|
||
fish = {
|
||
enable = true;
|
||
shellInit = "starship init fish | source";
|
||
};
|
||
starship = {
|
||
enable = true;
|
||
settings = {
|
||
shell = {
|
||
disabled = false;
|
||
fish_indicator = "";
|
||
bash_indicator = "BASH";
|
||
};
|
||
};
|
||
};
|
||
};
|
||
|
||
# Some programs need SUID wrappers, can be configured further or are
|
||
# started in user sessions.
|
||
# programs.mtr.enable = true;
|
||
# programs.gnupg.agent = {
|
||
# enable = true;
|
||
# enableSSHSupport = true;
|
||
# };
|
||
|
||
# List services that you want to enable:
|
||
|
||
# Enable the OpenSSH daemon.
|
||
services.openssh.enable = true;
|
||
services.openssh.settings.PasswordAuthentication = false;
|
||
# services.openssh.settings.PermitRootLogin = "proh";
|
||
services.nginx.enable = true;
|
||
security.acme = {
|
||
acceptTerms = true;
|
||
defaults = {
|
||
email = "glennpub@proton.me";
|
||
dnsProvider = "cloudflare";
|
||
# # location of your CLOUDFLARE_DNS_API_TOKEN=[value]
|
||
# # https://www.freedesktop.org/software/systemd/man/latest/systemd.exec.html#EnvironmentFile=
|
||
environmentFile = "/etc/nixos/.secrets/cloudflare_zone_dns_edit";
|
||
};
|
||
# certs."sondell.org" = {
|
||
# domain = "*.sondell.org";
|
||
# group = config.services.nginx.group;
|
||
# };
|
||
};
|
||
# networking.firewall.allowedTCPPorts = [ ... ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
# networking.firewall.enable = false;
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "23.11"; # Did you read the comment?
|
||
}
|