34 lines
844 B
Nix
34 lines
844 B
Nix
{
|
|
# pkgs,
|
|
# config,
|
|
# lib,
|
|
...
|
|
}: {
|
|
# Home Manager needs a bit of information about you and the
|
|
# paths it should manage.
|
|
home.username = "root";
|
|
home.homeDirectory = "/root";
|
|
programs = {
|
|
ssh = {
|
|
addKeysToAgent = "yes";
|
|
enable = true;
|
|
matchBlocks."*".identityFile = [
|
|
"/root/.ssh/tulpan"
|
|
];
|
|
};
|
|
|
|
# Let Home Manager install and manage itself.
|
|
home-manager.enable = true;
|
|
};
|
|
|
|
# This value determines the Home Manager release that your
|
|
# configuration is compatible with. This helps avoid breakage
|
|
# when a new Home Manager release introduces backwards
|
|
# incompatible changes.
|
|
#
|
|
# You can update Home Manager without changing this value. See
|
|
# the Home Manager release notes for a list of state version
|
|
# changes in each release.
|
|
home.stateVersion = "24.05";
|
|
}
|