22 lines
487 B
Nix
22 lines
487 B
Nix
{...}:
|
|
{
|
|
services.nginx = {
|
|
enable = true;
|
|
clientMaxBodySize = "10g";
|
|
# defaultHTTPListenPort = 1234;
|
|
};
|
|
services.cloudflared = {
|
|
enable = false;
|
|
# tunnels = {
|
|
# "tulpan" = {
|
|
# credentialsFile = "/etc/nixos/.secrets/tulpan-tunnel.json";
|
|
# default = "http_status:404";
|
|
# ingress = {
|
|
# "*.sondell.org" = "http://localhost:1234";
|
|
# "sondell.org" = "http://localhost:1234";
|
|
# };
|
|
# };
|
|
# };
|
|
};
|
|
}
|